TLS 1.2 upgrade notice: update browser and .NET

Published on January 14, 2016 in Uncategorized by Geotab

In April 2016, Geotab is removing support for the TLS 1.0 and 1.1 protocols. To ensure your applications continue to function, upgrade to at least .NET 4.5.

As of April 2016, Geotab will remove all support for the protocols TLS 1.0 and 1.1. After this date, any Geotab partner or customer whose browser or API client does not support TLS 1.2 will find that their applications or integrations that use the Geotab SDK will not work. Going forward, all new MyGeotab customers will only use TLS 1.2.

For the best security, Geotab recommends upgrading to TLS 1.2 as soon as possible for your organization. This means you should use at least .NET 4.5 and the most recent version of your preferred internet browser, where it is the default option.

Important: Please ensure that your technical teams upgrade to at least .NET 4.5 to ensure you support TLS 1.2.

What is TLS?

Transport Layer Security (TLS) is a protocol that ensures privacy between communicating applications and their users on the Internet. When a server and client communicate, TLS ensures that no third-party may eavesdrop or tamper with any message. TLS is the successor to the Secure Sockets Layer (SSL).

How to Check If You Are Affected:

Why is Geotab Upgrading to TLS 1.2?

At Geotab, we care deeply about security. Security is not a destination but a journey and a mind set. We have to observe what is going on out there and adjust accordingly.

TLS 1.0 is no longer secure. Exploits exist to downgrade a connection based on TLS 1.0 to an older version of the protocol. There is no active exploit affecting all of TLS 1.1, but the downgrade attack works on some versions and installations and academically speaking, TLS 1.1’s hash functions are under threat.

If using an older SSL/TLS protocol revision you could have someone sitting on the line and taking in your data while absolutely nothing about the connection indicated it. A compromised secure connection is no different from an insecure connection, but may give a false sense of security.

The revision and deprecation of protocols is an expected, occasional thing, as encryption techniques improve and processing speeds increase over time. This deprecation and notice is for our customers’ security. Anyone keeping up with the latest developments will already be secure, but those who have not kept up to date could end up using an insecure method.

Who Will Be Affected by the TLS Upgrade?

There are two primary parties who will be affected:

  1. Geotab partners or customers with third-party applications using the Geotab SDK who are using older builds of .NET or other environments that do not support TLS 1.2. Note: It is necessary to upgrade to at least .NET 4.5 to have support for TLS 1.2.
  2. Users on older browser versions. If you are not keeping up with the latest browser updates, everything you do online is at risk! Read this article for a detailed table showing the TLS support (as well as other security features) of the most commonly used desktop and mobile browsers: https://en.wikipedia.org/wiki/Transport_Layer_Security#Web_browsers

As always, the recommendation remains to use the most recent version of whichever web browser is available to you for the most up-to-date and secure browsing experience.

Technical Resources:

Related Posts: Geotab’s Security Policy on PCI Compliance
Geotab Datacenter Expands in 2015


If you liked this post, let us know!

Subscribe to

Geotab | Blog

Sign up for monthly news and tips from our award-winning fleet management blog. You can unsubscribe at any time.

Notice: This website or its third-party tools use cookies, which are necessary to its functioning and required to achieve the purpose illustrated in the  cookie policy.  By closing this banner, scrolling this page, clicking a link or continuing to browse otherwise, you agree to the use of cookies.